Server Error in '/' Application.

Jan 24, 2011 at 4:38 PM

I am a beginner. I start the application from Visaul Studio 2008 at the direction of installation
I always see a message that

The resource cannot be found.

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly.

Requested URL: /

 

what is wrong ? please help me !


Coordinator
Jan 24, 2011 at 5:52 PM

Kassi...

This was built using .NET 4.0 ASP.NET MVC 2.0 and Visual Studio Express 2010.

It should work fine in Visual Studio 2010.

The url that should be accessed is http://localhost:<port>/home/index

- Kishore

Jan 24, 2011 at 6:14 PM

Yes Kishore

I use Visual Studio 2010  Ultimate .NET 4.0 MVC 2  and Sql Express 2008

i start web app in VS 2010 /ide/CommonLibrary.CMS.sln and i see same error.

when i type in my browser  http://localhost:49740/home/index, i see same error

what is wrong

 

 

 

 

Feb 18, 2011 at 10:57 PM

I have the same problem as kassi. Please help.

Coordinator
Feb 19, 2011 at 5:03 AM

 

Please refer to http://insomniacgeek.com/how-to-fix-resource-not-found-error-with-your-asp-net-mvc-project/ . Once in a while when you have downloaded a ASP.NET MVC project, it will fail to start. All you get is a 404 error, or a Resource not found.  Here’s how to fix that. Go to the properties page of the Web project and select the Web tab. In the Start Action section, set it to Specific Page, but leave the textbox empty.

Feb 19, 2011 at 10:18 AM

Thank you kishore for your reply and for this great library.

I already tried this solution but it didn't fix my problem and i am still getting the same error!

Regards.

Feb 19, 2011 at 10:28 AM

I found the problem.

I have mvc 3 installed on my pc. The web project was referencing version 3 of mvc instead of version 2. (no idea why)

So i removed then added the reference again but targeting mvc assembly version 2.

Best regards.

Feb 23, 2011 at 1:34 PM

thanks eliebouzeid

i same mvc 3

now is working

 

Thanks again